Relution 5 Update Checkliste

Relution 5 Systemvorraussetzung

Mit dem Major Update Version 5 von Relution werden die Systemvorraussetzung für den Betrieb der Software angepasst. Bitte prüfen Sie vor dem Update der Software die Systemvorraussetzungen Ihrer Installation.

Wichtig: Bitte erstellen Sie vor dem Update ein Backup der Datenbank und der Relution Installation.

Java

Relution 5 setzt mindestens eine Java Runtime Version 11 vorraus.

Untersützte Versionen sind:

  • Java 11
  • Java 12
  • Java 13
  • Java 14
  • Java 15

Wir empfehlen AdoptOpenJDK 11 (LTS) für den Einsatz mit Relution.

Datenbank Server

Ältere Datenbank Server Version werden mit Relution 5 nicht mehr unterstützt.

Untersützte Datenbanken sind:

Reverse Proxy / REST API Pfade

Mit Relution 5 wurde die URL Pfade vereinheitlicht. Bitte prüfen Sie ob Ihre Reverse Proxy Konfiguration aktuell ist.

Nginx Konfiguration für Relution 5:

Update Pfad

Damit Relution 5 bei Neuinstallation schneller startet, haben wir alte Datenbank Schema Migrationsskripte entfernt. Bitte stellen Sie sicher, dass vor einem Update zu Relution 5 die Version 4.79.4 oder neuer installiert wurde.

Weitere Informationen erhalten Sie hier.

Bitte installieren Sie nach dem Update die neuesten Relution Client Apps für Android und iOS.

Checkliste

  • Backup erstellt
  • Datenbank Server geprüft
    • MySQL mind. 8.0
    • MariaDB mind. 10.3
    • MS SQL Server mind. 2016
    • PostgreSQL mind. 11.0
    • Cockroack mind. 20.2
    • Oracle -> PostgreSQL Migration
  • Java Runtime aktualisiert
    • Mindestens Version 11
  • Reverse Proxy Konfiguration überprüft
  • Relution Update-Pfad
    • Version 4.79.4 wurde installiert
    • Version 5 kann installiert werden
  • Relution Apps Update verteilt