Lista de comprobación de la actualización de Relution 5

Requisitos del sistema de Relution 5


Con la gran actualización de la versión 5 de Relution se adaptan los requisitos del sistema para el funcionamiento del software. Por favor, compruebe los requisitos del sistema de su instalación antes de actualizar el software.

Importante: Por favor, haga una copia de seguridad de la base de datos y de la instalación de Relution antes de actualizar.

Java

Relution 5 requiere al menos la versión 11 de Java Runtime.

Las versiones de Java soportadas son:

  • Java 11
  • Java 12
  • Java 13
  • Java 14
  • Java 15

Recomendamos AdoptOpenJDK 11 (LTS) para su uso con Relution.

Servidor de base de datos

Las versiones más antiguas del servidor de bases de datos ya no son compatibles con Relution 5.

Las bases de datos soportadas son:

  • MySQL al menos la versión 8.0
  • MariaDB al menos la versión 10.3
  • MS SQL Server](https://www.microsoft.com/de-de/sql-server) al menos la versión 2016
  • PostgreSQL al menos la versión 11.0
  • CockroackDB al menos la versión 20.2
  • Oracle Database ya no es compatible. Por favor, migre a PostgreSQL

Proxy inverso / Rutas de la API REST

Con la Relution 5 las rutas URL han sido unificadas. Por favor, asegúrese de que la configuración de su proxy inverso está actualizada.

Configuración de Nginx para Relution 5:

Actualizar la ruta

Para que Relution 5 se inicie más rápido en una nueva instalación, hemos eliminado los antiguos scripts de migración de esquemas de bases de datos. Por favor, asegúrese de tener instalada la versión 4.79.4 o más reciente antes de actualizar a Relution 5.

Puedes obtener más información aquí.

Por favor, instale las nuevas aplicaciones cliente de Relution para Android e iOS después de la actualización.

Direcciones de correo electrónico

Con Relution 5, las direcciones de correo electrónico de los nuevos usuarios son únicas y no pueden ser utilizadas por otro usuario de la misma organización o de otra.

Lista de comprobación

  • Copia de seguridad creada
  • Verificación de la versión del servidor de la base de datos
    • MySQL min. 8.0
    • MariaDB min. 10.3
    • MS SQL Server min. 2016
    • PostgreSQL min. 11.0
    • Cockroack min. 20.2
    • Migración Oracle -> PostgreSQL
  • Java Runtime actualizado
    • Al menos la versión 11
  • Configuración del proxy inverso comprobada
  • Ruta de actualización de Relution
    • Se ha instalado la versión 4.79.4
    • Se puede instalar la versión 5
  • Actualización de aplicaciones de Relution distribuida